Installation from sourceedit

Installing or Curator from source is also possible. In order to do so requires that all dependent libraries are installed first.

If you have pip installed, then you can install from a gzipped file. If not, you have to uncompress the gzipped file and run python setup.py install.

That might look like this:

wget https://github.com/username/project/archive/#.#.#.tar.gz -O package.tar.gz
tar zxf package.tar.gz
cd package-#.#.#
python setup.py install

The dependencies are as follows

setuptoolsedit

Download ez_setup.py and run it using the target Python version. The script will download the appropriate version and install it for you:

wget https://bootstrap.pypa.io/ez_setup.py -O - | python

Note that you will need to invoke the command with superuser privileges to install to the system Python:

wget https://bootstrap.pypa.io/ez_setup.py -O - | sudo python

Alternatively, setuptools may be installed to a user-local path:

wget https://bootstrap.pypa.io/ez_setup.py -O - | python - --user

 

Urllib3edit

Download and install the urllib3 dependency (1.8.3 or greater):

  1. wget https://github.com/shazow/urllib3/archive/1.20.tar.gz -O urllib3-1.20.tar.gz
  2. pip install urllib3-1.20.tar.gz

or uncompress and run python setup.py install

 

clickedit

Download and install the click dependency (6.0 or greater):

  1. wget https://github.com/pallets/click/archive/6.7.tar.gz -O click-6.7.tar.gz
  2. pip install click-6.7.tar.gz

or uncompress and run python setup.py install

 

certifiedit

Download and install the certifi dependency. Always use the most recent version:

  1. wget https://github.com/certifi/python-certifi/archive/2018.01.18.tar.gz -O certifi.tar.gz
  2. pip install certifi.tar.gz

 

PyYAMLedit

Download and install the PyYAML dependency (3.10 or greater):

  1. wget http://pyyaml.org/download/pyyaml/PyYAML-3.12.tar.gz -O PyYAML-3.12.tar.gz
  2. pip install PyYAML-3.12.tar.gz

or uncompress and run python setup.py install

 

voluptuousedit

Download and install the voluptuous dependency (0.9.3 or greater):

  1. wget https://github.com/alecthomas/voluptuous/archive/0.9.3.tar.gz
  2. pip install 0.9.3.tar.gz

or uncompress and run python setup.py install

 

elasticsearch (python module)edit

Download and install the elasticsearch-py dependency:

  1. wget https://github.com/elastic/elasticsearch-py/archive/5.5.2.tar.gz -O elasticsearch-py.tar.gz
  2. pip install elasticsearch-py.tar.gz

or uncompress and run python setup.py install

 

elasticsearch-curator (python module)edit

Download and install Curator:

  1. wget https://github.com/elastic/curator/archive/v5.5.1.tar.gz -O elasticsearch-curator.tar.gz
  2. pip install elasticsearch-curator.tar.gz

or uncompress and run python setup.py install. At this point you could also run run_curator.py from the source directory as well.