Upgrade a self-installation of the APM integration to 8.5.2edit

This upgrade guide is for the Elastic APM integration. Only use this guide if both of the following are true:

  • You have a self-installation of the Elastic Stack, i.e. you’re not using Elastic Cloud.
  • You have already switched to and are running Fleet and the Elastic APM integration.

Prerequisitesedit

  1. Prior to upgrading to version 8.5.2, Elasticsearch, and Kibana must be upgraded to version 7.17. To upgrade Elasticsearch and Kibana, see the Elastic Stack Installation and Upgrade Guide
  2. Review the APM release notes, breaking changes, and Observability What’s new content.

Upgrade stepsedit

  1. Upgrade the Elastic Stack to version 8.5.2.

    The Elastic Stack (Elasticsearch and Kibana) must be upgraded before Elastic Agent. See the Elastic Stack Installation and Upgrade Guide for guidance.

  2. Upgrade Elastic Agent to version 8.5.2. As a part of this process, the APM integration will automatically upgrade to version 8.5.2.

    1. In Fleet, select Agents.
    2. Under Agents, click Upgrade available to see a list of agents that you can upgrade.
    3. Choose Upgrade agent from the Actions menu next to the agent you want to upgrade. The Upgrade agent option is grayed out when an upgrade is unavailable, or the Kibana version is lower than the agent version.

    For more details, or for bulk upgrade instructions, see Upgrade Elastic Agent