Elasticsearch Hadoop breaking changesedit

This list summarizes the most important breaking changes in Elasticsearch Hadoop 7.0.0. For the complete list, go to Elasticsearch Hadoop breaking changes.

Cascading Integration has been removededit

Each integration that we support incurs a cost for testing and maintenance as new features are added in ES-Hadoop. We’ve seen the usage statistics dropping for the Cascading integration over the last couple of years. These include download numbers, community posts, and open issues. Additionally, ES-Hadoop only supports the Cascading 2 line. Cascading is already into it’s 3.X line and we haven’t seen much interest or pressure to get on to any of the newer versions. Due to these factors, Cascading was deprecated in the 6.6 release, and has been removed in the 7.0.0 release.

Java 8 or higher now requirededit

ES-Hadoop 7.0.0 and above requires a minimum Java version of 1.8 or above. The library will no longer be compiled for Java 1.6 or Java 1.7.

Configuration Changesedit

es.input.use.sliced.partitions has been removed.