Support Matrix

The tables below display platform and software configurations that are eligible for support under our subscription offerings. Learn more about our support policy.

Don't see your favorite platform, JVM, or browser? Contact us.

Product and Operating System

  CentOS/RHEL
6.x/7.x
Oracle Enterprise
Linux 6/7
with RHEL
Kernel only
Ubuntu
12.04/14.04
SLES 11 SP4**/12 OpenSuSE
13.2
Windows
Server
2012/R2
Windows
Server
2008
Debian
7
Solaris/SmartOS Amazon Linux*
Elasticsearch 1.5.x                    
Elasticsearch 1.6.x                    
Elasticsearch 1.7.x                    
Elasticsearch 2.0.x                    
Elasticsearch 2.1.x                    
Elasticsearch 2.2.x                    
Elasticsearch 2.3.x                    
Elasticsearch 2.4.x                    
Logstash 1.x                    
Logstash 2.0.x                    
Logstash 2.1.x                    
Logstash 2.2.x                    
Logstash 2.3.x                    
Logstash 2.4.x                    

*We might ask you to move to newer versions of Amazon Linux as part of our support process
**Zip/tar.gz archives only. RPM installation is not supported on SLES 11.


Beats 1.x

  CentOS/RHEL
5x
CentOS/RHEL
6.x/7.x
Oracle Enterprise
Linux 6/7
with RHEL
Kernel only
Ubuntu
12.04/14.04
SLES 11 SP4**/12 OpenSuSE
13.2
Debian
6
Debian
7
Linux ARM Windows XP Windows
Server
2008
Windows
Server
2012/R2
Solaris/SmartOS FreeBSD OSX 10.11 AIX
Packetbeat     *2   *2 *2     *1 *2 *2   *1 *1    
Topbeat     *2   *2 *2     *1 *2 *2          
Filebeat     *2   *2 *2     *1 *2 *2   *1 *1    
Winlogbeat                   *2            

*1 only with self compilation therefore unsupported
*2 Binary provided but not supported
**Zip/tar.gz archives only. RPM installation is not supported on SLES 11.

Product and JVM

  Oracle JRE
1.6
Oracle JVM
1.7u55+
Oracle JVM
1.8u20+
IcedTea OpenJDK
1.6
IcedTea OpenJDK
1.7.0.55+
IBM
JVM 6
IBM
JVM 7
Azul
Zing
Elasticsearch 1.5.x                
Elasticsearch 1.6.x                
Elasticsearch 1.7.x                
Elasticsearch 2.0.x                
Elasticsearch 2.1.x                
Elasticsearch 2.2.x                
Elasticsearch 2.3.x                
Elasticsearch 2.4.x                
Logstash 1.x                
Logstash 2.0.x                
Logstash 2.1.x                
Logstash 2.2.x                
Logstash 2.3.x                
Logstash 2.4.x                

Supported Browsers *

  IE9 IE11+ Firefox Chrome Safari (Mac) Safari (iOS) Chrome (Android)
Kibana 3.1              
Kibana 4.x              

* Kibana only
Latest GA versions of listed browsers supported.

Product Compatibility

Supported Shield Versions

Shield Version Elasticsearch Version Compatibility Kibana Version Compatibility
1.0.x 1.4.2 - 1.7.x NA
1.1.x 1.4.2 - 1.7.x NA
1.2.x 1.5.0 - 1.7.x NA
1.3.x 1.5.0 - 1.7.x NA
2.0.x 2.0.x NA
2.1.x 2.1.x NA
2.2.x 2.2.x 4.4.x
2.3.x 2.3.x 4.5.x
2.4.x 2.4.x 4.6.x

Supported Marvel Versions

Marvel Version Elasticsearch Version Compatibility Shield Version Compatibility
1.3.x 1.5.x- 1.7.x 1.0.x - 1.3.x
2.0.x 2.0.x 2.0.x
2.1.x 2.1.x 2.1.x
2.2.x 2.2.x 2.2.x
2.3.x 2.3.x 2.3.x
2.4.x 2.4.x 2.4.x

Supported Kibana Versions

Kibana Version Elasticsearch Version Compatibility Shield Version Compatibility
4.0.0 - 4.1.x 1.4.x - 1.7.x 1.0.x - 1.3.x
4.2.x 2.0.x 2.0.x
4.3.x 2.1.x 2.1.x
4.4.x 2.2.x 2.2.x
4.5.x 2.3.x 2.3.x
4.6.x 2.4.x 2.4.x

Supported Beats Versions

Beats Version Elasticsearch Version Compatibility Logstash Version Compatibility Kibana Version Compatibility
1.x 1.4 and greater 1.5 and greater 4.1 and greater

Supported Watcher Versions

Watcher Version Elasticsearch Version Compatibility
1.0.x 1.5.0 - 1.7.x
2.0.x 2.0.x
2.1.x 2.1.x
2.2.x 2.2.x
2.3.x 2.3.x
2.4.x 2.4.x

Supported Graph Versions

Graph Version Elasticsearch Version Compatibility
2.3.x 2.3.x
2.4.x 2.4.x

Supported Reporting Versions

Reporting Version Kibana Version Compatibility
2.4.x 4.6.0+

Supported Logstash Versions

Logstash Version Elasticsearch Version Compatibility Shield Version Compatibility
1.5.x 1.0.0 and greater* 1.0.0 and greater**
2.0.x 1.0.0 and greater 1.0.0 and greater**
2.1.x 1.0.0 and greater 1.0.0 and greater**
2.2.x 1.0.0 and greater 1.0.0 and greater**
2.3.x 1.0.0 and greater 1.0.0 and greater**
2.4.x 1.0.0 and greater 1.0.0 and greater**

* Logstash 1.5.x only supports HTTP protocol for ES 2.0.0 and greater

** Node protocol is not Shield compatible

Supported ES-Hadoop Versions

ES-Hadoop Version Elasticsearch Version Compatibility Shield Version Compatibility
2.0.x 1.x 1.x
2.1.x 1.x 1.x
2.2.x 1.x and 2.x 1.x and 2.x
2.3.x 1.x and 2.x 1.x and 2.x
2.4.x 1.x and 2.x 1.x and 2.x