Matriz de suporte

As tabelas abaixo exibem as configurações de plataforma e software qualificadas para suporte sob as nossas ofertas de assinatura. Saiba mais sobre a nossa Política de Suporte e sobre a política de fim de vida útil do produto.

Não encontrou a sua plataforma, JVM ou navegador favorito? Fale conosco.

O download de nosso software requer TLSv1.2 ou superior. Alguns sistemas operacionais mais antigos (ou suas bibliotecas libcurl, curl e nss usadas pelo apt-get ou yum) podem precisar ser atualizadas para uma versão que habilite o suporte para TLSv1.2 para baixar arquivos usando instalações de pacotes. Consulte a documentação do seu sistema operacional para saber mais detalhes.

Elasticsearch

Última atualização: 2024-03-26

A partir da versão 7.12 e posteriores, oferecemos suporte para aarch64 com o mesmo conjunto de distribuições do x86_64.

A criptografia em repouso para o Elasticsearch via dm-crypt tem suporte em todos os sistemas operacionais Linux.

O suporte para as distribuições Linux listadas requer uma instalação nativa do Linux. O Subsistema Windows para Linux (WSL), por exemplo, não é compatível.

*Tem suporte com o kernel RHEL para todas as versões listadas e Oracle UEK do Elasticsearch 6.8.x em diante.

**Apenas arquivos Zip/tar.gz. A instalação do RPM não tem suporte no SLES 11.

***Podemos pedir que você mude para versões mais recentes do Amazon Linux como parte de nosso processo de suporte.

‡ CentOS 6, RHEL 6 e Oracle Enterprise Linux 6 não dão suporte para o pacote JDK 15+ desde a versão 7.9.2 devido a incompatibilidades com glibc.

O modo FIPS 140-2 requer Oracle JDK 11 (Elasticsearch 7.x) ou Oracle JDK 17 (Elasticsearch 8.13+) e o provedor de segurança FIPS Bouncy Castle BCJSSE

1 não é compatível em versões 7.17.x anteriores à 7.17.5

Kibana

Última atualização: 2024-03-26

A partir da versão 7.10 e posteriores, oferecemos suporte para aarch64 com o mesmo conjunto de distribuições do x86_64

O suporte para as distribuições Linux listadas requer uma instalação nativa do Linux. O Subsistema Windows para Linux (WSL), por exemplo, não é compatível.

Logstash

Última atualização: 2024-03-26

A partir da versão 7.14 e posteriores, oferecemos suporte para aarch64 no Linux com o mesmo conjunto de distribuições do x86_64

*Podemos pedir que você mude para versões mais recentes do Amazon Linux como parte de nosso processo de suporte

**Apenas arquivos Zip/tar.gz. A instalação do RPM não tem suporte no SLES 11.

***CentOS 6, RHEL 6 e Oracle Enterprise Linux 6 não dão suporte para JDK 15+.

Auditbeat

Última atualização: 2024-03-26

Filebeat

Última atualização: 2024-03-26

Functionbeat

Última atualização: 2024-01-17

Heartbeat

Última atualização: 2023-11-07

Metricbeat

Última atualização: 2024-03-26

Packetbeat

Última atualização: 2024-03-26

Winlogbeat

Última atualização: 2024-03-26

*Podemos pedir que você mude para versões mais recentes do Amazon Linux como parte de nosso processo de suporte.

**A compatibilidade se aplica ao pacote da CLI para implantar o Functionbeat em frameworks sem servidor. Os usuários devem observar que o Functionbeat chegará ao fim do suporte 12 meses após o lançamento da versão 8.5. O Elastic Serverless Forwarder (em disponibilidade geral) é um produto substituto para os usuários que desejam ingerir dados em um ambiente sem servidor.

Você também pode autocompilar sem suporte no Linux PPC/PPC64LE, Solaris/SmartOS e FreeBSD.

Observe que não serão disponibilizados pacotes do Homebrew para os Beats na versão 8.0 e superiores.

A partir da versão 8.0 e superiores, os Beats não oferecem suporte para sistemas operacionais de 32 bits.

Os instaladores MSI do Windows para Beats estão disponíveis na nossa página de downloads, mas atualmente estão na versão Beta.

****A partir de 7.17.19, as versões 7.17.x não oferecem suporte para MacOS 10.14, 10.15, CentOS 8, Debian 9, Windows 7, Windows 8 e Windows Server 2012 que atingiram o fim de sua vida útil.

Elastic Agent

Última atualização: 2024-03-26

Algumas entradas e integrações não têm suporte em todos os sistemas operacionais. Consulte a documentação para saber mais.

A partir da versão 7.16 e posteriores, oferecemos suporte para aarch64 no Linux com o mesmo conjunto de distribuições do x86_64

A partir da versão 8.2 e posteriores, os binários do MacOS são compatíveis com x86_64 e aarch64, e acomodam os chipsets M1 e M2 da Apple

Versão do sistema operacional otimizado para container do Google: cos97-lts

O Elastic Agent também tem suporte no Windows Server Datacenter Core equivalente ao Windows Server mencionado na matriz

O Elastic Agent não é compatível com sistemas operacionais de 32 bits.

O Elastic Agent não é compatível com o ISE do Windows PowerShell

*A partir de 7.17.19, as versões 7.17.x não oferecem suporte para MacOS 10.14, 10.15, CentOS 8, Debian 9, Windows 8 e Windows Server 2012 que atingiram o fim de sua vida útil.

Elastic Defend

Última atualização: 2024-03-26

*Somente Intel/AMD x64

Há suporte para o Linux ARM apenas na versão 7.16 e posteriores, e requer um kernel 5.4+

**Inclui suporte para o AWS Graviton

Endgame Sensor

Última atualização: 25/07/2023

*Para o Endgame Sensor 3.51 a 3.54, há suporte para arquiteturas de 32 bits e 64 bits; para versões posteriores à 3.54, há suporte apenas para arquiteturas de 64 bits (com exceção do Windows 7 SP1, conforme indicado abaixo).

**Para a versão 3.60 e anteriores, há suporte para sistemas Windows 7 SP1 de 32 e 64 bits. Para sensores de versão 3.61 e posteriores, não há suporte para o Windows 7 SP1

***O suporte para macOS 12 requer sensores de versão 3.60.2 ou posteriores

‡ O suporte para RHEL9, Ubuntu 22.04 e macOS 13 requer sensores de versão 3.62.5 ou posteriores

≠ O suporte para macOS 14 requer sensores de versão 3.64.4 ou posteriores

O suporte padrão para todas as versões é de 64 bits, a menos que especificado. Além disso, os processadores ARM não têm suporte para sistemas operacionais Windows e Linux. O chipset Apple M1 tem suporte.

Elastic Cloud Enterprise

Última atualização: 2024-03-26

O ECE 2.13 e até o ECE 3.3 também têm suporte no RHEL/CentOS 7.x com RH Docker 1.13 e Docker 18.09, respectivamente

*O ECE 2.13 e posteriores não são certificados ativamente nessas plataformas e têm suporte apenas de forma discricionária

**O ECE 3.5.1 e versões mais novas também têm suporte na combinação de sistema operacional marcada para hardware baseado em ARM

[1] incremento de versão para Podman 4.6.x

[2] incremento de versão para Docker 24.0

Os sistemas operacionais não especificados acima não têm suporte

Versões do Docker e do kernel Linux com suporte:
- O ECE requer que a contabilização de memória do kernel seja desabilitada para todos os cgroups de memória. Desabilite-a passando `cgroup.memory=nokmem` para o kernel no momento da inicialização.

APM Server

Última atualização: 2024-03-26

A partir da versão 8.0 e posteriores, oferecemos suporte para aarch64 no Linux com o mesmo conjunto de distribuições do x86_64

*Podemos pedir que você mude para versões mais recentes do Amazon Linux como parte de nosso processo de suporte

**Não há pacotes do Homebrew disponíveis para o APM Server na versão 8.0 e superiores

***O suporte para sistemas de 32 bits foi preterido e será removido em uma versão futura.

Última atualização: 11/02/2020

A partir da versão 7.7.0, o App Search é fornecido com o pacote do Enterprise Search.

Última atualização: 2024-03-26

Clientes de conector

Última atualização: 2024-03-26