Spaces method and path for this operation:
Refer to Spaces for more information.
Update an existing Timeline. You can update the title, description, date range, pinned events, pinned queries, and/or pinned saved queries of an existing Timeline.
Body
Required
The Timeline updates, along with the Timeline ID and version.
-
The timeline object of the Timeline or Timeline template that you’re updating.
Hide timeline attributes Show timeline attributes object
-
The Timeline's columns
Hide columns attributes Show columns attributes object
-
The time the Timeline was created, using a 13-digit Epoch timestamp.
-
The user who created the Timeline.
-
Object containing query clauses
Hide dataProviders attributes Show dataProviders attributes object
-
Hide and attributes Show and attributes object
-
Hide queryMatch attributes Show queryMatch attributes object
-
The type of data provider.
Values are
defaultortemplate.
-
-
ID of the Timeline's Data View
-
The Timeline's search period.
Hide dateRange attributes Show dateRange attributes object | null
-
The Timeline's description
-
EQL query that is used in the correlation tab
Hide eqlOptions attributes Show eqlOptions attributes object | null
-
Event types displayed in the Timeline
-
A list of row renderers that should not be used when in
Event renderersmodeValues are
alert,alerts,auditd,auditd_file,library,netflow,plain,registry,suricata,system,system_dns,system_endgame_process,system_file,system_fim,system_security_event,system_socket,threat_match, orzeek. -
Indicates when and who marked a Timeline as a favorite.
-
A list of filters that should be applied to the query
Hide filters attributes Show filters attributes object
-
A list of index names to use in the query (e.g. when the default data view has been modified)
-
Indicates whether the KQL bar filters the query results or searches for additional results, where:
filter: filters query resultssearch: displays additional search results
-
KQL bar query.
Hide kqlQuery attribute Show kqlQuery attribute object
-
The ID of the saved query that might be used in the Query tab
-
The ID of the saved search that is used in the ES|QL tab
-
The status of the Timeline.
Values are
active,draft, orimmutable. -
A unique ID (UUID) for Timeline templates. For Timelines, the value is
null. -
Timeline template version number. For Timelines, the value is
null. -
The type of Timeline.
Values are
defaultortemplate. -
The Timeline's title.
-
The last time the Timeline was updated, using a 13-digit Epoch timestamp
-
The user who last updated the Timeline
-
-
The
savedObjectIdof the Timeline or Timeline template that you’re updating. -
The version of the Timeline or Timeline template that you’re updating.
Responses
-
Indicates that the Timeline was successfully updated.
Hide response attribute Show response attribute object
-
Hide data attribute Show data attribute object
-
Hide persistTimeline attribute Show persistTimeline attribute object
-
Hide timeline attributes Show timeline attributes object
-
The Timeline's columns
Hide columns attributes Show columns attributes object
-
The time the Timeline was created, using a 13-digit Epoch timestamp.
-
The user who created the Timeline.
-
Object containing query clauses
Hide dataProviders attributes Show dataProviders attributes object
-
Hide and attributes Show and attributes object
-
Hide queryMatch attributes Show queryMatch attributes object
-
The type of data provider.
Values are
defaultortemplate.
-
-
ID of the Timeline's Data View
-
The Timeline's search period.
Hide dateRange attributes Show dateRange attributes object | null
-
The Timeline's description
-
EQL query that is used in the correlation tab
Hide eqlOptions attributes Show eqlOptions attributes object | null
-
Event types displayed in the Timeline
-
A list of row renderers that should not be used when in
Event renderersmodeValues are
alert,alerts,auditd,auditd_file,library,netflow,plain,registry,suricata,system,system_dns,system_endgame_process,system_file,system_fim,system_security_event,system_socket,threat_match, orzeek. -
Indicates when and who marked a Timeline as a favorite.
-
A list of filters that should be applied to the query
Hide filters attributes Show filters attributes object
-
A list of index names to use in the query (e.g. when the default data view has been modified)
-
Indicates whether the KQL bar filters the query results or searches for additional results, where:
filter: filters query resultssearch: displays additional search results
-
KQL bar query.
Hide kqlQuery attribute Show kqlQuery attribute object
-
The ID of the saved query that might be used in the Query tab
-
The ID of the saved search that is used in the ES|QL tab
-
The status of the Timeline.
Values are
active,draft, orimmutable. -
A unique ID (UUID) for Timeline templates. For Timelines, the value is
null. -
Timeline template version number. For Timelines, the value is
null. -
The type of Timeline.
Values are
defaultortemplate. -
The Timeline's title.
-
The last time the Timeline was updated, using a 13-digit Epoch timestamp
-
The user who last updated the Timeline
-
The
savedObjectIdof the Timeline or Timeline template -
The version of the Timeline or Timeline template
-
A list of all the notes that are associated to this Timeline.
Hide eventIdToNoteIds attributes Show eventIdToNoteIds attributes object
-
The time the note was created, using a 13-digit Epoch timestamp.
-
The user who created the note.
-
The last time the note was updated, using a 13-digit Epoch timestamp
-
The user who last updated the note
-
The
_idof the associated event for this note. -
The text of the note
-
The
savedObjectIdof the Timeline that this note is associated with -
The
savedObjectIdof the note -
The version of the note
-
-
A list of all the ids of notes that are associated to this Timeline.
-
A list of all the notes that are associated to this Timeline.
Hide notes attributes Show notes attributes object
-
The time the note was created, using a 13-digit Epoch timestamp.
-
The user who created the note.
-
The last time the note was updated, using a 13-digit Epoch timestamp
-
The user who last updated the note
-
The
_idof the associated event for this note. -
The text of the note
-
The
savedObjectIdof the Timeline that this note is associated with -
The
savedObjectIdof the note -
The version of the note
-
-
A list of all the ids of pinned events that are associated to this Timeline.
-
A list of all the pinned events that are associated to this Timeline.
Hide pinnedEventsSaveObject attributes Show pinnedEventsSaveObject attributes object
-
The time the pinned event was created, using a 13-digit Epoch timestamp.
-
The user who created the pinned event.
-
The last time the pinned event was updated, using a 13-digit Epoch timestamp
-
The user who last updated the pinned event
-
The
_idof the associated event for this pinned event. -
The
savedObjectIdof the timeline that this pinned event is associated with -
The
savedObjectIdof this pinned event -
The version of this pinned event
-
-
-
-
-
-
Indicates that the user does not have the required access to create a Timeline.
curl \
--request PATCH 'https://localhost:5601/api/timeline' \
--header "Authorization: $API_KEY" \
--header "Content-Type: application/json" \
--data '{
"timeline": {
"columns": [
{
"columnHeaderType": "not-filtered",
"id": "@timestamp"
},
{
"columnHeaderType": "not-filtered",
"id": "event.category"
}
],
"created": 1587468588922,
"createdBy": "casetester",
"dataProviders": [
{
"enabled": true,
"excluded": false,
"id": "id-d3a1d35a3e84a81b2f8f3859e064c224cdee1b4bcbf66f57d124dcc739c98e6b",
"name": "d3a1d35a3e84a81b2f8f3859e064c224cdee1b4bcbf66f57d124dcc739c98e6b",
"queryMatch": {
"field": "_id,",
"operator": ":",
"value": "d3a1d35a3e84a81b2f8f3859e064c224cdee1b4bcbf66f57d124dcc739c98e6b,"
}
}
],
"dataViewId": "security-solution-default",
"dateRange": {
"end": 1587456479201,
"start": 1587370079200
},
"description": "Investigating exposure of CVE XYZ",
"eqlOptions": {
"eventCategoryField": "event.category",
"query": "sequence\\n[process where process.name == \"sudo\"]\\n[any where true]",
"size": 100,
"timestampField": "@timestamp"
},
"eventType": "all",
"excludedRowRendererIds": [
"alert"
],
"favorite": [
{
"favoriteDate": 1741337636741,
"userName": "elastic"
}
],
"filters": [
{
"meta": {
"alias": "Custom filter name",
"disabled": false,
"index": ".alerts-security.alerts-default,logs-*",
"key": "@timestamp",
"negate": "false,",
"type": "exists",
"value": "exists"
},
"query": "{\"exists\":{\"field\":\"@timestamp\"}}"
}
],
"indexNames": [
".logs*"
],
"kqlMode": "search",
"kqlQuery": {
"filterQuery": null,
"kuery": {
"expression": "_id : *",
"kind": "kuery"
},
"serializedQuery": "{\"bool\":{\"should\":[{\"exists\":{\"field\":\"_id\"}}],\"minimum_should_match\":1}}"
},
"savedQueryId": "c7b16904-02d7-4f32-b8f2-cc20f9625d6e",
"savedSearchId": "6ce1b592-84e3-4b4a-9552-f189d4b82075",
"sort": {
"columnId": "@timestamp",
"sortDirection": "desc"
},
"status": "active",
"templateTimelineId": "6ce1b592-84e3-4b4a-9552-f189d4b82075",
"templateTimelineVersion": 12,
"timelineType": "default",
"title": "CVE XYZ investigation",
"updated": 1741344876825,
"updatedBy": "casetester"
},
"timelineId": "15c1929b-0af7-42bd-85a8-56e234cc7c4e",
"version": "WzE0LDFd"
}'