Breaking changesedit

Before you upgrade, you must review the breaking changes for each product you use and make the necessary changes so your code is compatible with 7.5.0.

  • If you’re upgrading from 5.n, make sure you check the breaking changes from 5.n to 6.n, as well as from 6.n to 7.n!
  • If you are using machine learning datafeeds that contain discontinued search or query domain specific language (DSL), the upgrade will fail. In 5.6.5 and later, the Upgrade Assistant provides information about which datafeeds need to be updated.