Upgrading Logstash to 7.0

Before upgrading Logstash:

If you are installing Logstash with other components in the Elastic Stack, also see the Elastic Stack installation and upgrade documentation.

Upgrading between non-consecutive major versions (5.x to 7.x, for example) is not supported. We recommend that you upgrade to 6.x, and then upgrade to 7.x.

Upgrade to Logstash 6.8 before upgrading to 7.0

If you haven’t already, upgrade to version 6.8 before you upgrade to 7.0. If you’re using other products in the Elastic Stack, upgrade Logstash as part of the Elastic Stack upgrade process.

Upgrading to Logstash 6.8 will give you a head-start on new 7.0 features, including the java execution engine and the strict field reference parser, while you’re still running 6.x. This step helps reduce risk and makes roll backs easier if you hit a snag.

Upgrading to 6.8 is required because the Elasticsearch index template was modified to be compatible with Elasticsearch 7.0 (the _type setting changed from doc to _doc).