Upgrading Using Package Managers

This procedure uses package managers to upgrade Logstash.

  1. Shut down your Logstash pipeline, including any inputs that send events to Logstash.
  2. Using the directions in the Package Repositories section, update your repository links to point to the 5.x repositories instead of the previous version.
  3. Run the apt-get upgrade logstash or yum update logstash command as appropriate for your operating system.
  4. Test your configuration file with the logstash --config.test_and_exit -f <configuration-file> command. Configuration options for some Logstash plugins have changed in the 5.x release.
  5. Restart your Logstash pipeline after updating your configuration file.