Kibana 6.1.2

Security Issues

  • Kibana versions before 6.1.2 and 5.6.6 but after 5.1.1 had a cross-site scripting (XSS) vulnerability via the colored fields formatter that could allow an attacker to obtain sensitive information from or perform destructive actions on behalf of other Kibana users. CVE ID: CVE-2018-3818

Users should upgrade to Kibana version 6.1.2 or 5.6.6. There are no known workarounds for this issue.

Enhancements

Dev Tools
  • [Fixes #15786] [Console] Adding autocomplete rules for composite agg #15787

Bug Fixes

Machine Learning
  • Disabled the ability to create forecasts for jobs that were created before 6.1.0.
  • Fixed the Anomaly Explorer such that it retains the chosen swim lane limits when you reload the page.
  • Fixed incorrect line positions in the Single Metric Viewer. When all data points had the same value, the Y-axis offset was not calculated correctly and the line was drawn in the wrong position or was invisible in the line chart.
Monitoring
  • Fixed situations where Kibana was showing the same information for different clusters in the Logstash Overview.
Platform
  • Update color field formatter #15837
Visualization
  • [Fixes #15843] Fix broken loader in 6.1 #15885
  • [Fixes #15594] fixes pie chart size to normal if labels are not applied #15641
Watcher
  • Fixed error that prevented users from creating threshold alerts with email actions.