Upgrade Elasticsearch

Upgrade Elasticsearchedit

Elasticsearch clusters can usually be upgraded one node at a time so upgrading does not interrupt service. For upgrade instructions, refer to Upgrading to Elastic 8.6.2.

Upgrade from 7.x

To upgrade to 8.6.2 from 7.16 or an earlier version, you must first upgrade to 7.17, even if you opt to do a full-cluster restart instead of a rolling upgrade. This enables you to use the Upgrade Assistant to identify and resolve issues, reindex indices created before 7.0, and then perform a rolling upgrade. You must resolve all critical issues before proceeding with the upgrade. For instructions, refer to Prepare to upgrade from 7.x.

Index compatibilityedit

Elasticsearch has full query and write support for indices created in the previous major version. If you have indices created in 6.x or earlier, you might use the archive functionality to import them into newer Elasticsearch versions, or you must reindex or delete them before upgrading to 8.6.2. Elasticsearch nodes will fail to start if incompatible indices are present. Snapshots of 6.x or earlier indices can only restored using the archive functionality to a 8.x cluster even if they were created by a 7.x cluster. The Upgrade Assistant in 7.17 identifies any indices that need to be reindexed or removed.

REST API compatibilityedit

REST API compatibility is a per-request opt-in feature that can help REST clients mitigate non-compatible (breaking) changes to the REST API.

FIPS Compliance and Java 17edit

Elasticsearch 8.6.2 requires Java 17 or later. There is not yet a FIPS-certified security module for Java 17 that you can use when running Elasticsearch 8.6.2 in FIPS 140-2 mode. If you run in FIPS 140-2 mode, you will either need to request an exception from your security organization to upgrade to Elasticsearch 8.6.2, or remain on Elasticsearch 7.x until Java 17 is certified. Alternatively, consider using Elasticsearch Service in the FedRAMP-certified GovCloud region.