Prerequisite

The Java High Level Rest Client requires Java 1.8 and can be used to send requests to an Elasticsearch cluster in a compatible version.