ZooKeeper module

The ZooKeeper module fetches statistics from the ZooKeeper service.

Compatibility

The ZooKeeper metricsets were tested with ZooKeeper 3.4.8 and are expected to work with all version >= 3.4.0. Versions prior to 3.4 do not support the mntr command.

Example configuration

The ZooKeeper module supports the standard configuration options that are described in Specify which modules to run. Here is an example configuration:

metricbeat.modules:
- module: zookeeper
  metricsets: ["mntr"]
  period: 10s
  hosts: ["localhost:2181"]

Metricsets

The following metricsets are available: