Upgrading to APM Server v7.0

Before upgrading to APM Server v7.0, there are some breaking changes in the APM Server and the APM UI that you should be aware of.

Upgrade Steps

Check the Product Compatibility matrix to determine if you need to upgrade Elasticsearch and Kibana.

  1. Upgrade Elasticsearch.
  2. Upgrade Kibana.
  3. Ensure all of your APM agents are upgraded to a version that supports APM Server >= 6.5. The agent/server compatibility matrix will help determine compatibility.
  4. Upgrade APM Server (see below if upgrading from an RPM or Deb install).
  5. Use the Kibana migration assistant, found in the Kibana Management tab, to migrate 6.x data to the 7.x format.

Upgrading from 6.x RPM or Deb install

When upgrading from an RPM or Deb install, you’ll be prompted with a warning saying the install is going to overwrite /etc/apm-server/apm-server.yml. Here’s what you should do:

  1. Back up your current apm-server.yml configuration file.
  2. Accept the "overwrite" option from the 7.0 install.
  3. Copy/Paste any configuration options you want to keep from the old config file to the new config file.