Maven Repositoryedit

The low-level REST client is subject to the same release cycle as elasticsearch. Replace the version with the desired sniffer version, first released with 5.0.0-alpha4. There is no relation between the sniffer version and the elasticsearch version that the client can communicate with. Sniffer supports fetching the nodes list from elasticsearch 2.x and onwards.

Maven configurationedit

Here is how you can configure the dependency using maven as a dependency manager. Add the following to your pom.xml file:

<dependency>
    <groupId>org.elasticsearch.client</groupId>
    <artifactId>sniffer</artifactId>
    <version>5.5.2</version>
</dependency>

Gradle configurationedit

Here is how you can configure the dependency using gradle as a dependency manager. Add the following to your build.gradle file:

dependencies {
    compile 'org.elasticsearch.client:sniffer:5.5.2'
}