APT repositoryedit

We use the PGP key D88E42B4, Elastic’s Signing Key, with fingerprint

4609 5ACC 8548 582C 1A26 99A9 D27D 666C D88E 42B4

to sign all our packages. PGP is available from http://pgp.mit.edu.

Signing Keyedit

Download and install the Public Signing Key:

wget -qO - https://packages.elastic.co/GPG-KEY-elasticsearch | sudo apt-key add -

Repository Configurationedit

Important

Debian 9 was recently released, and it uses OpenSSL 1.1.0 libraries, where earlier releases, including Debian 8, Ubuntu 12.04 - 16.04 LTS, and others used OpenSSL 1.0.0 libraries. As a consequence, a new repository has been introduced, in order to preserve the functionality of the old one, without causing collisions.

Please use the appropriate package or repository.

Add one of the following — noting the correct path, debian or debian9 — in your /etc/apt/sources.list.d/ directory in a file with a .list suffix, for example curator.list

deb [arch=amd64] http://packages.elastic.co/curator/5/debian stable main

or

deb [arch=amd64] http://packages.elastic.co/curator/5/debian9 stable main

After running sudo apt-get update, the repository is ready for use.

Warning

Use the file edit method described above to add the Curator repository. Do not use add-apt-repository as it will add a deb-src entry as well, but we do not provide a source package. If you have added the deb-src entry, you will see an error like the following:

Unable to find expected entry 'main/source/Sources' in Release file (Wrong sources.list entry or malformed file)

Just delete the deb-src entry from the /etc/apt/sources.list.d/curator.list file and the installation should work as expected.

Binary Package Installationedit

The APT version of Curator is a binary version. What this really means is that the source is frozen, and all required libraries are bundled with the curator binary, so there are no conflicts.

The packages resulting from the creation process have been tested on Debian 8, and Ubuntu 12.04, 14.04, & 16.04. It was also tested on Debian 7, but that failed due to a libc library mismatch. This binary package may work on other similar or derivative variants, but they have not been tested.

sudo apt-get update && sudo apt-get install elasticsearch-curator

This will install the necessary files into /opt/elasticsearch-curator and make a symlink at /usr/bin/curator that points to the curator binary in the aforementioned directory.