Can’t log in after upgrading to 6.3.0edit

Symptoms:

  • Native realm credentials don’t work after $version upgrade or snapshot restore.
  • Error message: "Security index is not on the current version - the native realm will not be operational until the upgrade API is run on the security index"

Resolution:

You must upgrade the .security index to the 6.x format. For instructions, see Upgrading internal indices.

There are two situations where it’s necessary to manually upgrade the .security index:

  • After upgrading directly to 6.3.0 from 5.5 or earlier.
  • After restoring a snapshot from 5.5 or earlier that contains a .security index in the old format to a 6.0 cluster.