Migrate to the Beats input plugin for Logstashedit

Filebeat requires the Beats input plugin for Logstash. For information about getting started with this plugin, see Configure Logstash to listen for Beats input in the Elastic Stack getting started tutorial.

In both the 1.5.x and 2.x versions of Logstash, this plugin can be loaded in parallel with the Lumberjack plugin used by the Logstash Forwarder.

If you have a large number of servers that you want to migrate from Logstash Forwarder to Filebeat, we recommend that you keep the Lumberjack plugin and load the Beats input plugin on the same Logstash instances, but set up the Beats input plugin to use a different port. After you have migrated all the machines to Filebeat, you can remove the Lumberjack plugin.

We realize that opening additional ports may not be feasible in your organization. Another option for phased migration to Filebeat is to ship data from Logstash Forwarder directly to the Beats input plugin.

Important

This data shipping path is only supported for migrating to Filebeat and will no longer be supported when Logstash Forwarder reaches End of Life.

What’s required?

  • The Beats input plugin for Logstash version 2.2.8 or later.
  • SSL must be explicitly enabled in the Beats input plugin (ssl => true) because SSL is on by default with Logstash Forwarder. The SSL/TLS configs should be the same for both the Logstash Forwarder and Filebeat instances.