Agent/Server compatibilityedit

Below is a chart that outlines the compatibility between different versions of the APM agents and the APM Server.

APM Server version 6.5 introduced a new way for APM agents to communicate with the APM Server. To take advantage of new features, it is recommended that you update to the newest version of the applicable agent.

Go Agent Compatibilityedit

Agent VersionAPM Server Version

1.x

>= 6.5

Java Agent Compatibilityedit

Agent VersionAPM Server Version

1.x

>= 6.5

Node.js Agent Compatibilityedit

Agent VersionAPM Server Version

1.x

6.2-6.x

2.x

>= 6.5

Python Agent Compatibilityedit

Agent VersionAPM Server Version

2.x, 3.x

6.2-6.x

4.x

>= 6.5

Ruby Agent Compatibilityedit

Agent VersionAPM Server Version

1.x

6.4-6.x

2.x

>= 6.5

RUM Agent Compatibilityedit

Agent VersionAPM Server Version

0.x

6.3-6.4

1.x

6.4

2.x, 3.x

>= 6.5