19 février 2015 Technique

Elasticsearch 1.4.4 and 1.3.9 Released

Par Kevin Kluge

Today, we released Elasticsearch 1.4.4 and 1.3.9. This is a small bug fix release, mainly including a packaging fix for our RPM and DEB packages if you are using Lucene expression scripts . You can download Elasticsearch 1.4.4 here.


The 1.4.3 RPM and DEB packages were missing dependencies for Antlr and ASM. These dependencies are required to use Lucene expression scripts with Elasticsearch. Since the changes in 1.4.3 for Groovy, we expect a lot more people will be using expressions scripts, so we quickly released 1.4.4.

The release also fixes a few bugs around cluster pending tasks. And it fixes a bug where a negative interval on date histograms could cause an OutOfMemoryError.

The 1.4.4 release notes as well as 1.3.9 release notes the list out all the changes.


As always, we would love to hear from you. Please let us know what you think on Twitter via @elasticsearch or by filing an issue on GitHub.