28 juillet 2014 Technique

Elasticsearch 1.3.1 Released

Par Clinton Gormley

Today, we are happy to announce the bugfix release of Elasticsearch 1.3.1, based on Lucene 4.9. You can download it and read the full changes list here: Elasticsearch 1.3.1.

This release fixes a backwards compatibility bug (#7055) in index recovery. This bug does not cause data loss and upgrading to Elasticsearch 1.3.1 will fix the problem. It will affect any user who tries to upgrade to version 1.3.0, whose indices still include segments which were written to in any of these versions of Elasticsearch:

  • Elasticsearch 0.90.7
  • Elasticsearch 0.90.2
  • any version before Elasticsearch 0.90.0

The bug  prevents the recovery of replicas for these older indices.  An index that has segments from these versions, and has replicas enabled, will reach status yellow, but never green.  The exceptions in the logs will look like this:

    IllegalArgumentException[No enum constant org.apache.lucene.util.Version.x.x.x]

Certain versions of Lucene are missing constants which represent minor Lucene versions, and incorrect version numbers have been recorded in some segments.  LUCENE-5850 has been opened to address this issue in Lucene. This issue should have been caught by our backwards compatibility tests, but was missed because of the missing constant in Lucene.  The test suite will be improved to cover that eventuality in the future.

This release also fixes a few minor aggregation bugs, which are listed in the release notes.

Please download Elasticsearch 1.3.1, try it out, and let us know what you think @elasticsearch. You can report any problems on the GitHub issues page.