Elasticsearch 0.20.4


See issues on GitHub

Release Notes

Upgrade Notes:

  • Upgrading from 0.19 requires a full cluster restart.

Breaking Changes:

  • Shared Gateway has been deprecated (2459)
  • Snappy compression has been deprecated (2458)
  • Plugins Installer: Allow to download plugins from download.elasticsearch.org (#2507)
  • Sometimes MapperParsingException and sometimes not (#2354)

Bug fixes:

  • Deb package wrongly includes additional lucene libraries (#2599)
  • Support MultiPhrasePrefix (MatchQuery.Type.PHRASE_PREFIX) in Highlighters (#2596)
  • Indexes created from index request might not replica initial doc to replica (#2594)