07 Oktober 2015 Veröffentlichungen

Elasticsearch 2.0.0-rc1 released

Von Clinton Gormley

Today, we are happy to announce the release of Elasticsearch 2.0.0-rc1, based on Lucene 5.2.1. Elasticsearch 2.0 is feature frozen. This is the last planned release candidate before 2.0.0 GA.

IMPORTANT: This is a release candidate and is intended for testing purposes only. Elasticsearch 2.0.0-rc1 is not compatible with 2.0.0-beta1 or 2.0.0-beta2, and there is no guarantee that it will be compatible with Elasticsearch 2.0.0 GA.

DO NOT DEPLOY IN PRODUCTION

You can download Elasticsearch 2.0.0-rc1 and read the full changes list here.

Change logs for the commercial plugins can be found here:

The changes in this release candidate consist mostly of minor bug fixes and tidy ups, with the occasional enhancement like the points_only optimization for geo-shape fields and, in Shield, a caching interface which can be used by custom realms.

Thank you to those of you who tested out 2.0.0-beta1 and 2.0.0-beta2 and reported problems. Given that this is the last planned preview release before 2.0.0 GA, we would appreciate as many testers as possible so that we can catch and fix issues before releasing the GA.

Elasticsearch Migration Plugin

The Elasticsearch Migration Plugin will help you to check whether you need to upgrade your indices, or take any other action, before trying out Elasticsearch 2.0.0-rc1. It will to detect issues like ancient Lucene 3 indices and problematic mappings that will no longer work in the upcoming 2.0.0.

You can find the instructions for this plugin in the Elasticsearch Migration repository.

Happy testing!

The more beta testers we have, the sooner we can release Elasticsearch 2.0.0 GA, so please download Elasticsearch 2.0.0-rc1, try it out, and let us know what you think on Twitter (@elastic) or on our forum. You can report any problems on the GitHub issues page.